让网维变得简单,快速,准确。拒绝浪费时间,解放出更多的时间陪陪家人。 注册 | 登陆
浏览模式: 标准 | 列表分类:ROS

dnspod多线高级版V3(ROS更新DDNS)

ROS脚本
  1. #DDNS Token-ID 
  2. :global tid "10002"  
  3. #DDNS Token
  4. :global tsn "85c4cece0ced14dba4837d13c2cab0e0"  
  5. #DDNS域名  
  6. :global rhost "域名(例如www.cat-home.org)"  
  7. #以下不需要修改  
  8. :global host [:pick $rhost ([:find $rhost "."]+1) [:len $rhost]]  
  9. :global zhost [:pick $rhost 0 [:find $rhost "."]]  
  10. /tool fetch url=("http://www.cat-home.org/dnspod/index.php\?tid=$tid&tsn=$tsn&ym=$host&zym=$zhost") mode=http keep-result=no  

DNSPOD Token申请地址
https://support.dnspod.cn/Kb/showarticle/tsid/227/

» 阅读全文

Tags: dnspod, ddns, 脚本, 多线, adsl

智能pppoe断线记录

 

ROS脚本(无需修改任何内容,自适应兼容。建议30秒以上运行一次)
  1. :global sjc 0  
  2. :global adslnumjc 0  
  3. :global oldadjc  
  4. :foreach pallc in=[/int pppoe-client find disabled=nodo={  
  5. :set adslnumjc ($adslnumjc+1)  
  6. :foreach ujc in=([/int pppoe-client get $pallc running]=yes) do={ 
  7. :if ($ujc=true) do={
  8. :set sjc (sjc+1)}}} 
  9. :if ((!($oldadjc = $sjc)) = true) do={  
  10. :log warning ("当前" . $sjc . "/" . $adslnumjc . "条拨号线路工作正常。")  
  11. }  

不会用自己面壁,无需多说...

» 阅读全文

Tags: ros, 脚本, pppoe, 拨号, 日志

ROS路由VPLS+BGP基础应用

 

假设某总公司R1的LAN1需要和分公司R2的LAN3进行L2桥接,并且LAN1和LAN3在同一个网段,要求LAN1和LAN3里的终端机器可以互相访问,支持MAC通讯,支持IPX通讯。(当然前提是LAN1和LAN3里的终端和终端之间IP不能冲突。)如果ISP禁止R1和R2之间进行BGP通讯需要先嵌套一个加密隧道,PPTP,L2TP,SSTP...等等都行。

» 阅读全文

Tags: ros, vpls, bgp, 桥接, bridge

温度电压异常报警

ROS脚本代码
  1. #定义温度报警阀值比如30度  
  2. :local tempbeep 30  
  3. #定义电压报警阀值比如23.2V  
  4. :local volbeep 232  
  5. :if (([/system health get temperature]>$tempbeep) || ([/system health get voltage]>$volbeep)) do={  
  6. :beep length=200ms frequency=3000  
  7. :delay 200ms  
  8. :beep length=200ms frequency=3500  
  9. :delay 200ms  
  10. :beep length=200ms frequency=3000  
  11. :delay 200ms  
  12. :beep length=200ms frequency=3500  
  13. :delay 200ms  
  14. :beep length=200ms frequency=3000  
  15. :delay 200ms  
  16. }  

 首先你的RB设备必须具备温度传感器和电压传感器,否则请不要使用。

» 阅读全文

Tags: ros, 温度, 电压, 报警, 监测

ROS防御内网攻击

本策略适用于防范UDP流量攻击(比如阿拉丁UDP攻击器)。TCP连接数攻击限制下单机连接数就行了,我就不多说了。

首先要新建一个网桥,将自己内网卡加入到桥接。

ROS防火墙脚本
  1. /interface bridge settings set use-ip-firewall=yes
  2. /ip firewall filter add action=add-src-to-address-list address-list=att address-list-timeout=10m chain=input connection-rate=10M-4294967295 protocol=udp src-address=192.168.0.0/24
  3. /ip firewall mangle add action=add-src-to-address-list address-list=att address-list-timeout=10m chain=postrouting connection-rate=10M-4294967295 protocol=udp src-address=192.168.0.0/24

修改IP为自己的内网IP地址范围。

ROS计划任务脚本
  1. :global attip
  2. :global defint
  3. :global taa 0
  4. :global nowmonth
  5. :global allmonth jan,feb,mar,apr,may,jun,jul,aug,sep,oct,nov,dec
  6. :foreach lizi in=[$allmonth] do={
  7. :if ([:pick [/system clock get date] 0 3]=$lizi) do={
  8. :set nowmonth ($taa+1)}
  9. :set taa ($taa + 1)}
  10. :global atttime ([:pick [/system clock get date] 7 11].$nowmonth.[:pick [/system clock get date] 4 6]."-".[/system clock get time]);
  11. :foreach fatt in=[/ip firewall address-list find list=att] do={
  12. :set attip [/ip firewall address-list get $fatt address]
  13. :if ([/interface bridge nat find arp-dst-address=($attip."/32")]="") do={
  14. /interface bridge nat add action=src-nat arp-dst-address=($attip."/32") chain=srcnat mac-protocol=arp comment=("att-".$atttime)}}
  15. :foreach fattd in=[/interface bridge nat find] do={
  16. :if ([/ip firewall address-list find list=att address=[:pick [/interface bridge nat get $fattd arp-dst-address] 0 ([:len [/interface bridge nat get $fattd arp-dst-address]]-3)]]="") do={
  17. /interface bridge nat remove $fattd}}

设置为定时循环执行,建议间隔时间为3-5秒左右为宜。

本策略原理是将攻击者的IP记录下来,加入攻击者的IP到桥防火墙,攻击者的IP将在ARP缓存超时后(WIN7系统5次测试计算后得到平均值为20秒左右。)无法和ROS通讯,因为找不到ROS的MAC,包括流量攻击也打不上来,因为找不到目标。(进入桥防火墙后即使攻击者再手工绑定路由MAC也无法成功。)
缺点:若客户机在攻击前已绑定路由MAC,则防御无法生效。因为ARP缓存不会超时。

» 阅读全文

Tags: ros, 内网, 攻击, udp, 流量