让网维变得简单,快速,准确。拒绝浪费时间,解放出更多的时间陪陪家人。 注册 | 登陆
浏览模式: 标准 | 列表分类:ROS

ROS的ADSL多线映射脚本

映射脚本自动绑定到默认路由的接口更新IP

--------------对NAT规则备注名进行查找-----------------
:global adcmname "3389"
:global adgw [/ip route get [/ip route find static=yes active=yes dynamic=yes distance=1] gateway]
:global ip [/ip add get [find network=$adgw] address]
:global newip [:pick $ip 0 [:find $ip "/"]]
:global oldip [/ip fi nat get [/ip fi nat find comment=$adcmname] dst-address]
:if ($newip != $oldip) do={
        :log info [/ip fi nat set [/ip firewall nat find comment=$adcmname] dst-address=$newip]
}

» 阅读全文

Tags: ros, adsl, 多线, 映射, 脚本

统计在线人数专业版

#内网地址段改为自己的
/ip firewall address-list add address=192.168.1.0/24 disabled=no list=lan
/ip firewall mangle add action=add-src-to-address-list address-list=Online address-list-timeout=1m chain=prerouting comment=tongji disabled=no src-address-list=lan

/system scheduler
add comment=tongji disabled=no interval=3m name="\CD\B3\BC\C6" on-event="#\D7\EE\B4\F3\D1\AD\BB\B7\B4\CE\CA\FD\r\
    \n:global rmaxlimit 5000\r\
    \n:global r 0\r\
    \n:global rn\r\
    \n:global rs\r\
    \n:global ravg\r\
    \n:global rmax\r\
    \n:if ([:len \$ravg] = 0) do={\r\
    \n:set ravg 0\r\
    \n:global rn 0\r\
    \n:global rs 0\r\
    \n:global rmax 0}\r\
    \n:if (\$rs = \$rmaxlimit) do={\r\
    \n:global rn \$ravg\r\
    \n:global rs 1}\r\
    \n:foreach b in=[/ip firewall add find list=\"Online\"] do={:set r (\$r+1)}\r\
    \n:if (\$rmax < \$r) do={:set rmax \$r}\r\
    \n:set rs (\$rs+1)\r\
    \n:set rn (\$rn+\$r)\r\
    \n:global ravg (\$rn / \$rs)\r\
    \n:log warning (\"\B5\B1\C7\B0\D4\DA\CF\DF\BF\CD\BB\A7\BB\FA\" . \$r . \"\CC\A8,\C6\BD\BE\F9\D4\DA\CF\DF\BF\CD\BB\A7\BB\FA\"\
    \_. \$ravg . \",\D7\EE\B8\DF\D4\DA\CF\DF\C0\FA\CA\B7\" . \$rmax . \"\CC\A8,\B5\B1\C7\B0\CD\B3\BC\C6\B4\CE\CA\FD\" . \$rs . \
    \"\A1\A3\")" policy=reboot,read,write,policy,test,password,sniff,sensitive start-date=jan/01/1970 start-time=00:00:00

» 阅读全文

Tags: 统计, 在线, 人数, ros, 脚本

ROS路由状态查看0.5

ROS路由状态查看0.5
更新时间:2012/2/23
更新内容:调整了延时值,判断参数,加强程序稳定性。修改了配置界面,将IP和配置界面放在一起方便调试。修正了账号密码错误时不断弹出错误提示的BUG。

ROS路由状态查看0.4
更新时间:2011/12/14
更新内容:调整了延时值,添加了查看QUEUE TREE内限速状态。

ROS路由状态查看0.3
更新时间:2011/11/24
更新内容:修正了配置服务后必须关闭程序再打开才能正常使用的BUG。调整了执行细节,以加快获取速度和降低获取数据出错的概率。

ROS路由状态查看0.2
功能简介:可以在不告知终端用户ROS账号密码的情况下方便终端用户查看ROS内的各接口状态。打开程序后按F12进入服务配置界面。必须配置开启服务后方可正常使用。
操作说明:先运行压缩包内的2个控件程序进行安装。配置服务请按F12进入。
不多说上图说明一切。目前本程序公开免费提供。

 

» 阅读全文

Tags: ros, 状态, 查看, api, 流量

ROS统计客户机TCP和UDP连接数量

#内网段IP

:global ipnetmask "192.168.0."

#内网IP起止

:for aaa from 1 to 254 do={

:global s 0

:global e 0

:foreach a in=[/ip firewall connection find src-address~($ipnetmask . $aaa)] do={

:if ([/ip firewall connection get $a protocol]="tcp") do={

:set s ($s+1)}

:if ([/ip firewall connection get $a protocol]="udp") do={

:set e ($e+1)}

}

:put ($ipnetmask . $aaa . " tcp-" . $s . " udp-" . $e)}

由于本脚本过于暴力,CPU不够牛的自觉绕路,省得卡掉线还怪我。看不懂也请自觉绕路,看得懂的自行修改下内网IP段就能用了。

» 阅读全文

Tags: ros, 统计, 客户机, 连接数

基本的OSPF配置

下面举例如何配置一个简单的OSPF网络,我们假设以下网络:

 

例如网络包含3台路由器,并连接到10.10.1.0/24的网络里,每个路由器都添加了一个从属网段

IP地址配置如下,路由器R1

 [admin@MikroTikR1]/ip address add address=10.10.1.1/24 interface=ether1

 [admin@MikroTikR1]/ip address add address=10.10.1.11/24 interface=ether2

 [admin@MikroTikR1]/ip address add address=210.13.1.0/28 interface=ether3

路由器R2

 [admin@MikroTikR2]/ip address add address=10.10.1.2/24 interface=ether1

 [admin@MikroTikR2]/ip address add address=10.10.1.12/24 interface=ether2

 [admin@MikroTikR2]/ip address add address=172.16.1.0/16 interface=ether3

路由器R3

 [admin@MikroTikR3]/ip address add address=10.10.1.3 /24 interface=ether1

 [admin@MikroTikR3]/ip address add address=10.10.1.13/24 interface=ether2

 [admin@MikroTikR3]/ip address add address=192.168.1.0/24 interface=ether3

这里有3OSPF配置的基本要素:

·         启用OSPF instance

·         OSPF区域配置

·         OSPF网络配置

基本信息配置在/routing ospf instance菜单下。对于高级的OSPF设置,需要运行多个OSPF instances,默认的instance配置是可以的,我只需要启用默认instance

R1:

[admin@MikroTikR1] /routing ospf instance> add name=default

R2:

[admin@MikroTikR2] /routing ospf instance> add name=default

R3:

[admin@MikroTikR3] /routing ospf instance> add name=default

显示OSPF instance信息:

[admin@MikroTikR1] /routing ospf instance> print

Flags: X - disabled

 0   name="default" router-id=0.0.0.0 distribute-default=never

     redistribute-connected=as-type-1 redistribute-static=as-type-1

     redistribute-rip=no redistribute-bgp=no redistribute-other-ospf=no

     metric-default=1 metric-connected=20 metric-static=20 metric-rip=20

     metric-bgp=auto metric-other-ospf=auto in-filter=ospf-in

out-filter=ospf-out

如同你看到的router-id0.0.0.0,意思是路由器将使用其中一个路由器IP地址作为router-id。在大多事例中建议设置loopback(回路) IP地址作为router-idLoopback IP地址是虚拟的,软件地址被用于网络识别,最大的好处是loopback地址总是存在且活动的,不会因为物理网卡连接断开而失效。 OSPF协议将它应用在路由器通信中,通过router-id识别路由器。Loopback接口配置如下:

创建一个bridge借口,并取名为loopback

[admin@MikroTikR1] /interface bridge> add name=loopback

添加ip地址:

[admin@MikroTikR1] > ip address add address=10.255.255.1/32 interface=loopback

配置router-id

[admin@MikroTikR1] /routing ospf instance> set 0 router-id=10.255.255.1

这个配置可以用于其它路由器R2R3

下一步配置OSPF Area

注意:记住backbone area-id总是0.0.0.0

最后一步添加OSPFnetwork到对应的area

R1

[admin@MikroTikR1] /routing ospf network> add network=210.13.1.0/28 area=backbone

[admin@MikroTikR1] /routing ospf network> add network=10.10.1.0/30 area=backbone

[admin@MikroTikR1] /routing ospf network> add network=10.10.1.4/30 area=backbone

你可以规划网段,通过设置相应的子网掩码,例如分配10.10.1.0/30, 10.10.1.4/30, 10.10.1.8/30的网段,可以规定OSPF路由的范围,你也可以这样设置OSPF的子网:

[admin@MikroTikR1] /routing ospf network> add network=10.10.1.0/'''24''' area=backbone

R2:

[admin@MikroTikR2] /routing ospf network> add network=172.16.1.0/16 area=backbone

[admin@MikroTikR2] /routing ospf network> add network=10.10.1.0/24 area=backbone

R3:

[admin@MikroTikR3] /routing ospf network> add network=192.168.1.0/24 area=backbone

[admin@MikroTikR3] /routing ospf network> add network=10.10.1.0/24 area=backbone

你可以核实你的OSPF操作是否生效:

  • 查看OSPF interface菜单,确定动态项目已经被创建:

[admin@MikroTikR1] /routing ospf interface> print

  • 检查你的OSPF neighborsDRBDR被选举

[admin@MikroTikR1] /routing ospf neighbor> print

  • 创建路由器的路由表(确定OSPF路由存在,注意看前缀):

[admin@MikroTik_CE1] > ip route print

 

» 阅读全文

Tags: ros, 网络, 配置, 简单, 举例