让网维变得简单,快速,准确。拒绝浪费时间,解放出更多的时间陪陪家人。 注册 | 登陆
浏览模式: 标准 | 列表Tag:更新

dnspod多线高级版V4(ROS更新DDNS)

ROS脚本
  1. #DDNS Token-ID
  2. :global tid "10002"
  3. #DDNS Token
  4. :global tsn "85c4cece0ced14dba4837d13c2cab0e0"
  5. #DDNS域名
  6. :global rhost "域名(例如www.cat-home.org)"
  7. #ROS系统版本(5X,6X)
    :global rver "6X"
  8. #以下不需要修改
  9. :global host [:pick $rhost ([:find $rhost "."]+1) [:len $rhost]]
  10. :global zhost [:pick $rhost 0 [:find $rhost "."]]
  11. :if (rver = "6X") do={
  12. /tool fetch url=("https://cat-home.org/dnspod/index.php\?tid=$tid&tsn=$tsn&ym=$host&zym=$zhost") keep-result=no
  13. } else={
  14. /tool fetch url=("http://www.cat-home.org/dnspod/index.php\?tid=$tid&tsn=$tsn&ym=$host&zym=$zhost") mode=http keep-result=no}

DNSPOD Token申请地址
https://support.dnspod.cn/Kb/showarticle/tsid/227/

本站提交限制为每10分钟最多10次。规定时间范围内超出提交数量将被忽略更新任务。

» 阅读全文

Tags: ros, ddns, 域名, 更新, dnspod

创建DDNS项目

项目名称:DDNS系统
项目目的:让动态IP绑定到本站提供的顶级域名
项目已实现功能:
1.允许用户自注册本DDNS系统的帐号密码。
2.允许用户自助修改密码。
3.允许用户自行(添加/删除)自己需要的二级域名。(目前挂接在joinros.com主域名下。)
4.允许用户使用wget或者其他脚本更新自己的二级域名。
注册地址:http://www.cat-home.org/ddns/reg.html
用户中心:http://www.cat-home.org/ddns/login.html

更新时间:2016/06/11
更新说明:找到同子域名可能会添加2次记录的BUG。(当提交子域名包含某些字符时会产生。)已经修复。更新脚本支持https,在6X版本的情况下可以使用,使用https提交更加安全。

更新时间:2015/07/07
更新说明:添加一个ROS-3X的DDNS脚本,方便ROS-3X用户使用。在3.24版本上测试通过。

ROS5X-6X脚本(10-15分钟执行一次)
  1. #DDNS本站帐号
  2. :global ddnsuser "用户名"  
  3. #DDNS本站密码
  4. :global ddnspass "密码"
  5. #ROS系统版本(5X,6X)
  6. :global rver "5X"
  7. #DDNS域名(本站添加的子域名)
  8. :global zhost "hello"
  9. #以下不需要修改 
  10. :if (rver = "5X") do={
  11. /tool fetch url=("http://www.cat-home.org/ddns/goddns.php\?user=$ddnsuser&passwd=$ddnspass&zym=$zhost") mode=http keep-result=no
  12. } else={
  13. /tool fetch url=("https://cat-home.org/ddns/goddns.php\?user=$ddnsuser&passwd=$ddnspass&zym=$zhost") keep-result=no
  14. }

» 阅读全文

Tags: 域名, ddns, ros, 更新, 脚本

DNSPOD接口更新专用公告

2015.5.14 添加支持Token方式登录,也同时支持旧的帐号密码登录方式。一个接口同时支持2种登录方式。
使用方式见下文
dnspod多线高级版V3(ROS更新DDNS)

2015.5.10 添加自动判断子域名是否存在,若不存在则尝试创建子域名。之前使用本接口必须先添加子域名,方可正常使用。现在会智能判断是否需要新建子域名。让接口使用更方便。
使用方式见下文
dnspod多线高级版V2(ROS更新DDNS)

» 阅读全文

Tags: ddns, ros, dnspod, 更新, api

esxcli 命令安装ESXI5补丁(转)

在esxi4中可以用vihostupdate安装补丁,但到了ESXI5版本后就不支持了,改用esxcli software vib commands命令(且支持第三方软件包),其可以在vCLI,vMA及ESXi shell中命令环境下运行,现以ESXi shell环境为例,其它类似:

      前提条件:
                     1.  关闭要升级主机所有虚拟机
                     2.  把主机进入维护模式
                     3.  若主机加入了HA,则要从HA移出或停用HA
                     4.  启用主机SSH服务



      步骤:
                     1. 上官网下载最新补丁:
                          http://www.vmware.com/patchmgr/findPatch.portal  

                     2.  通过Secure File Transfer Client类似软件或vmware vSphere Client把补丁文件传到主机存储上

                    
                     3.  安装补丁:  
                          先用PUTTY软件登主机,再运行下面命令:
                          esxcli  software  vib  install  -d="/vmfs/volumes/system/ESXI500-201109001.zip"
                          

» 阅读全文

Tags: esxi, 虚拟机, 补丁, 更新, 升级