让网维变得简单,快速,准确。拒绝浪费时间,解放出更多的时间陪陪家人。 注册 | 登陆
浏览模式: 标准 | 列表Tag:dnspod

dnspod多线高级版V4(ROS更新DDNS)

ROS脚本
  1. #DDNS Token-ID
  2. :global tid "10002"
  3. #DDNS Token
  4. :global tsn "85c4cece0ced14dba4837d13c2cab0e0"
  5. #DDNS域名
  6. :global rhost "域名(例如www.cat-home.org)"
  7. #ROS系统版本(5X,6X)
    :global rver "6X"
  8. #以下不需要修改
  9. :global host [:pick $rhost ([:find $rhost "."]+1) [:len $rhost]]
  10. :global zhost [:pick $rhost 0 [:find $rhost "."]]
  11. :if (rver = "6X") do={
  12. /tool fetch url=("https://cat-home.org/dnspod/index.php\?tid=$tid&tsn=$tsn&ym=$host&zym=$zhost") keep-result=no
  13. } else={
  14. /tool fetch url=("http://www.cat-home.org/dnspod/index.php\?tid=$tid&tsn=$tsn&ym=$host&zym=$zhost") mode=http keep-result=no}

DNSPOD Token申请地址
https://support.dnspod.cn/Kb/showarticle/tsid/227/

本站提交限制为每10分钟最多10次。规定时间范围内超出提交数量将被忽略更新任务。

» 阅读全文

Tags: ros, ddns, 域名, 更新, dnspod

DNSPOD接口更新专用公告

2015.5.14 添加支持Token方式登录,也同时支持旧的帐号密码登录方式。一个接口同时支持2种登录方式。
使用方式见下文
dnspod多线高级版V3(ROS更新DDNS)

2015.5.10 添加自动判断子域名是否存在,若不存在则尝试创建子域名。之前使用本接口必须先添加子域名,方可正常使用。现在会智能判断是否需要新建子域名。让接口使用更方便。
使用方式见下文
dnspod多线高级版V2(ROS更新DDNS)

» 阅读全文

Tags: ddns, ros, dnspod, 更新, api

dnspod多线高级版V3(ROS更新DDNS)

ROS脚本
  1. #DDNS Token-ID 
  2. :global tid "10002"  
  3. #DDNS Token
  4. :global tsn "85c4cece0ced14dba4837d13c2cab0e0"  
  5. #DDNS域名  
  6. :global rhost "域名(例如www.cat-home.org)"  
  7. #以下不需要修改  
  8. :global host [:pick $rhost ([:find $rhost "."]+1) [:len $rhost]]  
  9. :global zhost [:pick $rhost 0 [:find $rhost "."]]  
  10. /tool fetch url=("http://www.cat-home.org/dnspod/index.php\?tid=$tid&tsn=$tsn&ym=$host&zym=$zhost") mode=http keep-result=no  

DNSPOD Token申请地址
https://support.dnspod.cn/Kb/showarticle/tsid/227/

» 阅读全文

Tags: dnspod, ddns, 脚本, 多线, adsl

【通知】本站DNSPOD对接API接口已修复

本站DNSPOD对接API接口失效
从2014.10.16开始失效,恢复时间不明,需要等到官方发布新的API文档。
2014/10/17 10:34

本站DNSPOD对接API接口已修复
2014/10/17 19:00

» 阅读全文

Tags: dnspod, ddns, api, 对接, 接口

dnspod多线高级版V2(ROS更新DDNS)

ROS脚本
  1. #DDNS帐号  
  2. :global user "用户名"  
  3. #DDNS密码  
  4. :global pass "密码"  
  5. #DDNS域名  
  6. :global rhost "域名(例如www.cat-home.org)"  
  7. #以下不需要修改  
  8. :global host [:pick $rhost ([:find $rhost "."]+1) [:len $rhost]]  
  9. :global zhost [:pick $rhost 0 [:find $rhost "."]]  
  10. /tool fetch url=("http://www.cat-home.org/dnspod/index.php\?user=$user&passwd=$pass&ym=$host&zym=$zhost") mode=http keep-result=no  
  11. }  

懒得说明,不会用自己面壁去。

» 阅读全文

Tags: dnspod, ddns, 脚本, 多线, adsl