让网维变得简单,快速,准确。拒绝浪费时间,解放出更多的时间陪陪家人。 注册 | 登陆
浏览模式: 标准 | 列表Tag:ros

CTS穿透自动协议切换脚本(已添加脚本)

近期由于CTS2,CTS5(青岛服)PPTP协议出现异常,本站非常重视该问题,并且希望今后能避免这种问题出现。为此编写了自动切换协议脚本。用户只需修改脚本里对应的几个参数,然后定时执行,即可在侦测到问题时自动更换连接穿透服务器的协议。建议用户将该脚本加入到定时运行,若之前已存在CTS的连接,则会自动更名。建议5-10分钟循环执行一次。(取消了切换到PPTP)

» 阅读全文

Tags: ros, cts, vpn, 穿透, 切换

云交换公测使用简介

内测服务器IP为cts7.cat-home.org,有自助页面,和穿透自助差不多。
在自助页面添加VRF标识后,使用以下脚本来对接到服务器。终端路由只会接收到同VRF标识的其他终端路由表推送。
所以如果想多个节点的内网互通首先需要让多个账号的VRF标识一致才行,修改或添加VRF标识需要在WEB自助里断开下客户端,重连后生效。当在2边ROS的ip route里看到对端的网段为ADO状态即为成功对接。

###定义OSPF的ID###(随便填,但是尽量随机写一个)
:global ospfid "2.2.2.2"
###定义对端内网段###
:global dstnet "192.168.88.0/24"
/routing ospf instance
set [ find default=yes ] redistribute-connected=as-type-1 router-id=$ospfid
/routing ospf network add area=backbone network=172.32.56.1/32
/ip route rule add dst-address=172.32.56.0/24 table=main
###以下规则要移到顶端###
/ip firewall nat add action=accept chain=srcnat comment="CSW" dst-address=$dstnet

建议在防火墙和标记中对目标地址为对端内网段的范围进行action=accept
不明白的地方可以+Q群71773725问

示意图:

» 阅读全文

Tags: 云交换, ros, 加速, 互通, 局域网

RB,CCR官方设备选购参考

RB,CCR都属于mikrotik官方出品的原装正版设备。不同的型号性能不同,用户需要针对自己的环境做出正确的设备选择。以下参考均包含了策略性能消耗。

网吧环境参考:
30M以内---RB951UI
150M以内---RB750GR3
250M以内---RB3011
500M以内---CCR1009

小区环境参考:
70户以内---RB750GR3
200户以内---RB3011
300户以内---CCR1009

» 阅读全文

Tags: ros, rb, ccr, 官方, 正版

dnspod多线高级版V4(ROS更新DDNS)

ROS脚本
  1. #DDNS Token-ID
  2. :global tid "10002"
  3. #DDNS Token
  4. :global tsn "85c4cece0ced14dba4837d13c2cab0e0"
  5. #DDNS域名
  6. :global rhost "域名(例如www.cat-home.org)"
  7. #ROS系统版本(5X,6X)
    :global rver "6X"
  8. #以下不需要修改
  9. :global host [:pick $rhost ([:find $rhost "."]+1) [:len $rhost]]
  10. :global zhost [:pick $rhost 0 [:find $rhost "."]]
  11. :if (rver = "6X") do={
  12. /tool fetch url=("https://cat-home.org/dnspod/index.php\?tid=$tid&tsn=$tsn&ym=$host&zym=$zhost") keep-result=no
  13. } else={
  14. /tool fetch url=("http://www.cat-home.org/dnspod/index.php\?tid=$tid&tsn=$tsn&ym=$host&zym=$zhost") mode=http keep-result=no}

DNSPOD Token申请地址
https://support.dnspod.cn/Kb/showarticle/tsid/227/

本站提交限制为每10分钟最多10次。规定时间范围内超出提交数量将被忽略更新任务。

» 阅读全文

Tags: ros, ddns, 域名, 更新, dnspod

ROS日志服务器1.91

程序名称:ROS日志服务器
程序用途:用于集中接收ROS日志,方便查看集中管理的ROS日志信息,可过滤非正常信息,支持中文日志记录。
当前已实现功能:
1.接收ROS日志(端口为默认UDP 514)
2.过滤非正常信息。(比如其他程序对日志端口发包)
3.支持中文日志记录。
4.记录到数据库
5.按时间分页浏览
6.添加按关键字查询指定日期日志
7.临时记录当前过滤的信息到缓冲区,并允许查看被过滤的信息
8.添加IP内容搜索功能
9.添加系统语言检测,增加英文界面环境。

» 阅读全文

Tags: ros, log, system, info, 日志